鸿 网 互 联 www.68idc.cn

Apache Qpid 拒绝服务漏洞(CVE-2012-4458)

来源:互联网 作者:佚名 时间:2014-03-03 20:21
Apache Qpid cpp在实现上存在较长的零宽度类型数据造成的拒绝服务漏洞,AMQP类型解析器因为可能在客户端属性映射(client-propert

发布日期:2013-03-05
更新日期:2013-03-11

受影响系统:
Apache Group Qpid
描述:
--------------------------------------------------------------------------------
BUGTRAQ  ID: 58376
 CVE(CAN) ID: CVE-2012-4458
 
Apache Qpid(Open Source AMQP Messaging)是一个跨平台的企业通讯解决方案,实现了高级消息队列协议。
 
Apache Qpid cpp在实现上存在较长的零宽度类型数据造成的拒绝服务漏洞,AMQP类型解析器因为可能在客户端属性映射(client-properties map)中发送任意类型,所以存在预认证问题。这样在发送零宽度元素的数组后虽然不消耗带宽,,但是服务器解码后会需要存储空间,在某些系统中,特殊的SIZE值会触发OOM killer,并中断服务器进程,导致拒绝服务。
 
<*来源:Florian Weimer (Weimer@CERT.Uni-Stuttgart.DE)
 
  链接:https://bugzilla.redhat.com/show_bug.cgi?id=861234
 *>

建议:
--------------------------------------------------------------------------------
厂商补丁:
 
Apache Group
 ------------
 目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
 

linux

网友评论
<