鸿 网 互 联 www.68idc.cn

Moodle Amazon S3 Repository安全绕过漏洞(CVE-2012-6087)

来源:互联网 作者:佚名 时间:2014-02-27 18:10
Moodle进行证书验证过程中,使用(lib)cURL

发布日期:2013-09-16
更新日期:2013-09-20

受影响系统:
Moodle Amazon S3 Repository
描述:
--------------------------------------------------------------------------------
BUGTRAQ  ID: 62408
CVE ID: CVE-2012-6087

Moodle是一个课程管理系统(CMS),,也被叫做学习管理系统(LMS)或虚拟学习环境(VLE)

Moodle进行证书验证过程中,使用(lib)cURL's CURLOPT_SSL_VERIFYHOST的方式不安全,存在安全漏洞,攻击者可利用此漏洞执行中间人攻击,绕过安全限制,执行未授权操作。

<*来源:Thijs Kinkhorst (kink@squirrelmail.org)
 
  链接:https://bugzilla.redhat.com/show_bug.cgi?id=892700
*>

建议:
--------------------------------------------------------------------------------
厂商补丁:

Moodle
------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:


https://github.com/tpyo/amazon-s3-php-class/pull/36
https://github.com/tmuras/amazon-s3-php-class/commit/07bb73fe2ad2c74e0d1af395a391ddb8d0fcaa7c

linux

网友评论
<