鸿 网 互 联 www.68idc.cn

当前位置 : 服务器租用 > 网站安全 > 漏洞分析 > >

Coppermine Photo Gallery跨站脚本及SQL注入漏洞

来源:互联网 作者:佚名 时间:2012-11-07 20:43
受影响系统:Coppermine Photo Gallery 1.4.14不受影响系统:Coppermine Photo Gallery 1.4.15描述:Coppermine是用PHP编写的多用途集成web图形库脚本。 Coppermine实现上存在输入验证漏洞,远程攻击者可能利用此漏洞在用户浏览器中执行恶意代码。
受影响系统:
Coppermine Photo Gallery 1.4.14 不受影响系统:
Coppermine Photo Gallery 1.4.15 描述:
Coppermine是用PHP编写的多用途集成web图形库脚本。 Coppermine实现上存在输入验证漏洞,远程攻击者可能利用此漏洞在用户浏览器中执行恶意代码。 Coppermine的util.php和reviewcom.php文件没有正确地验证某些参数输入,允许远程攻击者通过注入任意SQL命令控制SQL查询;docs/showdoc.php文件没有正确地验证h和t参数输入便返回给了用户,这可能导致在用户浏览器会话中执行任意HTML和脚本代码。 厂商补丁:
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载: http://downloads.sourceforge.net/coppermine/cpg1.4.15.zip


网友评论
<