鸿 网 互 联 www.68idc.cn

当前位置 : 服务器租用 > 操作系统维护 > 其它 > >

MacPorts Error:Current platform "darwin 16&quot

来源:互联网 作者:佚名 时间:2017-09-04 12:35
tags: #MacPorts #错误故障 环境: macOS 10.x,Terminal 问题表现 在使用 port 命令时,出现这样的错误提示: Error: Current platform "darwin 16" does not match expected platform "darwin 15" Error: If you upgraded your OS, please follow the migr

tags: #MacPorts #错误故障

环境: macOS 10.x,Terminal

问题表现

在使用 port 命令时,出现这样的错误提示:

Error: Current platform "darwin 16" does not match expected platform "darwin 15" Error: If you upgraded your OS, please follow the migration instructions: <https://trac.macports.org/wiki/Migration>

解决办法

此问题是“port”命令(即 MacPorts 工具)无法工作。可能是因为 macOS 系统升级,Macports 没有升级造成。

手动升级 Macports

先查看 macOS 的版本,然后去 MacPorts 官网 http://www.macports.org/ 下载对应的版本安装包,并安装。

然后“port”命令可以使用之后,用命令行再升级 ports tree 等。可顺带再更新已经安装的各软件(ports)。

sudo port selfupdate,更新 MacPorts 和 ports tree

ps: 更新所有(已安装的ports)可更新的软件:sudo port upgrade outdated

[正文结束]

[更新记录]

20161222,记录

网友评论
<