鸿 网 互 联 www.68idc.cn

当前位置 : 服务器租用 > 网站制作教程 > php > >

解决php动态库libicui18n报错问题

来源:互联网 作者:佚名 时间:2021-12-04 14:22
本篇文章带大家介绍php动态库libicui18n报错问题。有一定的参考价值,有需要的朋友可以参考一下,希望对大家有所帮助。 php动态库libicui18n报错 安装完成ffmpeg出现动态库libicui18n报错,不存在 $ php -vdyld: Library not loaded: /usr/local/opt/icu4c/li
本篇文章带大家介绍php动态库libicui18n报错问题。有一定的参考价值,有需要的朋友可以参考一下,希望对大家有所帮助。

php动态库libicui18n报错

安装完成ffmpeg出现动态库libicui18n报错,不存在

$ php -v
dyld: Library not loaded: /usr/local/opt/icu4c/lib/libicui18n.63.dylib
  Referenced from: /usr/local/opt/php@7.2/bin/php
  Reason: image not found
[1]    31174 abort      php -v

通过网上查找资料了解到php新版本的动态库7.2.16不能使用63版本,通过升级php可以解决问题。 【推荐学习:PHP视频教程】

使用brew升级php

$ brew upgrade php72
==> Upgrading 1 outdated package:
php@7.2 7.2.16 -> 7.2.20
==> Upgrading php@7.2 
==> Installing dependencies for php@7.2: apr, argon2, libssh2, jemalloc, libev, nghttp2, curl-openssl, freetds, libpq and libsodium
==> Installing php@7.2 dependency: apr
==> Downloading https://homebrew.bintray.com/bottles/apr-1.7.0.mojave.bottle.tar.gz
==> Downloading from https://akamai.bintray.com/3a/3a245185ed7280d1a19e7c639786b4c21dd0088878be8ac87ca58510eb5c9cc1?__gda__=exp=1563530722~hmac=8e94698ea6aa458b7dfea49d1cde602217ab9a2
######################################################################## 100.0%
==> Pouring apr-1.7.0.mojave.bottle.tar.gz
==> Caveats
apr is keg-only, which means it was not symlinked into /usr/local,
because Apple's CLT package contains apr.

If you need to have apr first in your PATH run:
  echo 'export PATH="/usr/local/opt/apr/bin:$PATH"' >> ~/.zshrc

一切结束之后执行php查看版本:

$ php -v
PHP 7.2.20 (cli) (built: Jul  5 2019 12:51:26) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.2.20, Copyright (c) 1999-2018, by Zend Technologies

以上就是解决php动态库libicui18n报错问题的详细内容,更多请关注鸿网互联其它相关文章!

上一篇:详解PHP中的mysqli_affected_rows()方法
下一篇:没有了
网友评论
<