鸿 网 互 联 www.68idc.cn

当前位置 : 服务器租用 > 网站制作教程 > php > >

详解如何安装php扩展-amqp

来源:互联网 作者:佚名 时间:2021-12-04 14:21
本篇文章带大家介绍如何安装php扩展-amqp。有一定的参考价值,有需要的朋友可以参考一下,希望对大家有所帮助。 推荐:《PHP视频教程》 安装php扩展(我用的php7.2版本) php是用amqp调用RabbitMQ,所以先下载ampq $ wget https://pecl.php.net/get/amqp-1.9

本篇文章带大家介绍如何安装php扩展-amqp。有一定的参考价值,有需要的朋友可以参考一下,希望对大家有所帮助。

推荐:《PHP视频教程》

安装php扩展(我用的php7.2版本)

php是用amqp调用RabbitMQ,所以先下载ampq

$ wget https://pecl.php.net/get/amqp-1.9.3.tgz #下载
$ tar -xvf amqp-1.9.3.tgz #解压
$ cd amqp-1.9.3$ /usr/local/php/bin/phpize #用phpize生成编译文件,注意查看你的php在哪里
$ ./configure --with-php-config=/usr/local/php/bin/php-config

到这一步,我这里报错了:checking for amqp using pkg-config… configure: error: librabbitmq not found

这个错误提示还要安装一个:rabbitmq-c

去这里下载:https://github.com/alanxz/rabbitmq-c/releases

$ wget https://github.com/alanxz/rabbitmq-c/archive/v0.9.0.tar.gz
$ tar -xvf v0.9.0.tar.gz
$ cd rabbitmq-c-0.9.0/

准备configure的时候,发现没有configure,0.9改成cmake了,靠,安装一下cmake

$ yum -y install cmake
$ cmake . -DCMAKE_INSTALL_PREFIX=/usr/local/rabbitmq-c-0.9.0 #指定安装目录
$ make
$ make install

然后回过头去再编译amqp-1.9.3

$ ./configure --with-php-config=/usr/local/php/bin/php-config --with-amqp --with-librabbitmq-dir=/usr/local/rabbitmq-c-0.9.0$ make
$ make install

make报错!

发现点蛛丝马迹,上面进入了/usr/local/rabbitmq-c-0.9.0/lib 目录,查看一下发现/usr/local/rabbitmq-c-0.9.0/没有lib,但有个lib64位。

处理一下:

$ cp -R /usr/local/rabbitmq-c-0.9.0/lib64/ /usr/local/rabbitmq-c-0.9.0/lib

接着干:make && make install ,OK。

【php扩展-amqp】安装

加入到php.ini 查看一下!

extension=amqp.so

【php扩展-amqp】安装

扩展安装成功,这时候就可以用PHP操作RabbitMQ了。

以上就是详解如何安装php扩展-amqp的详细内容,更多请关注鸿网互联其它相关文章!

网友评论
<