鸿 网 互 联 www.68idc.cn

当前位置 : 服务器租用 > 电脑学堂 > 网吧技术 > >

不配置回指路由 多网段网络如何互联

来源:互联网 作者:佚名 时间:2015-02-13 08:43
不配置回指路由,就实现多网段网络互联,这有相当的实际需求。特别针对以下几种情况: 1、随着网络的复杂化,本来局域网是一个网段。后来因需要划分了多个网段,但是由于机器较多逐个修改IP地址和网关比较麻烦的情况。 2、出口的路由器为傻瓜产品无法自己添

  不配置回指路由,就实现多网段网络互联,这有相当的实际需求。特别针对以下几种情况:

  1、随着网络的复杂化,本来局域网是一个网段。后来因需要划分了多个网段,但是由于机器较多逐个修改IP地址和网关比较麻烦的情况。
  2、出口的路由器为傻瓜产品无法自己添加静态路由,以及仅能对本地直连网段做NAT。
  3、懒人,连路由都懒的配的懒人或配不好的新学。

  拓扑结构:

  1、PC1在VLAN 10中,IP地址是192.168.10.0/24
  2、PC2在VLAN20中,IP地址是192.168.20.0/24
  3、路由器在VLAN30中,IP地址是192.168.30.0/24
  4、中间的交换机为三层交换或者是路由器(不需要VLAN)。

  配置关键点:

  1、三层交换机的VLAN10 VLAN20 VLAN30虚接口要起PROXY-ARP协议(CISCO默认是开启的此处采用的是CISCO设备,因此配置中体现不出来)。相关配置如下:

!
    interface FastEthernet3/0
    switchport access vlan 10
    !
    interface FastEthernet3/1
    switchport access vlan 20
    !
    interface FastEthernet3/2
    switchport access vlan 30
    !
    interface Vlan10
    ip address 192.168.10.1 255.255.255.0
    !
    interface Vlan20
    ip address 192.168.20.1 255.255.255.0
    !
    interface Vlan30
    ip address 192.168.30.1 255.255.255.0
    

  2、下面PC机的网关可以设置为自身也可以设置为VLAN虚接口的网关。

  3、出口路由器的内网IP地址掩码要变小(只要能够包含内网的相关网段即可),此处为了方便选用了16bit,IP地址是192.168.30.2/16,无需添加任何静态路由。

  相关配置如下:


interface FastEthernet2/0
    ip address 192.168.30.2 255.255.0.0
    duplex auto
    speed auto

    R3# show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
        E1 - OSPF external type 1, E2 - OSPF external type 2
        i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
        ia - IS-IS inter area, * - candidate default, U - per-user static route
        o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    C? ? 192.168.0.0/16 is directly connected, FastEthernet2/0
    R3#


  四、测试结果如下:

R3#ping 192.168.10.2

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.10.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 20/72/120 ms
    R3#ping 192.168.20.2

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.20.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 60/76/116 ms

 
图1

 

网友评论
<