鸿 网 互 联 www.68idc.cn

当前位置 : 服务器租用 > 电脑学堂 > 网吧技术 > >

ROS路由-PCQ限速让限速更稳定更智能

来源:互联网 作者:佚名 时间:2015-02-06 10:48
前言: PCQ限速对于某些带宽不是很足的网吧来说,确实有点问题,必须你网吧只有15M的光纤,如果你做PCQ限速2M吧(我想2M对于100台机器来说的网吧已经是最大限度了),PCQ开启设置为14M吧,关闭设置为6M!如果有一个人用讯雷下载东西的话。网吧15马上占满,PC
前言:

  PCQ限速对于某些带宽不是很足的网吧来说,确实有点问题,必须你网吧只有15M的光纤,如果你做PCQ限速2M吧(我想2M对于100台机器来说的网吧已经是最大限度了),PCQ开启设置为14M吧,关闭设置为6M!如果有一个人用讯雷下载东西的话。网吧15马上占满,PCQ就会开启,但一旦开启后。你网速就会变到6M以下,那么PCQ就在那里不停的关闭和开启了,这样不单达不到智能限速的效果。还会增加ROS的负担!CPU占用。。所以我就一直想把智能和普通限速做在一起,让讯雷或者其他下载不会乱触发PCQ的流量,但最终还是失败了!启发,我想出了一个既可以动态限速,也可以静态限速的方法!例如,还是15M的光纤,100台机器的网吧。我静态设置为3M,这样的话,正常来说。4个人下载东西的话,也只占12M,那么还剩3M,足够其他玩Q和打网游的机器了!

  但如果5个人下载的话?怎么办?带宽马上到了15M了。呵呵,那其他玩网游的肯定会卡死!

  不用怕,我智能设置为大于14M触发另一个脚本,脚本的内容大概就是关闭原来的3M静态限速,开启1.5M的静态限速,这样一算,1.5*5=7.5M了,再加上玩网游的人,基本上就稳定在10M左右了!

  然后再设置一个脚本,当总流量少于6M的话(也就算没那么多人下载了,流量下来了)那么1.5M的静态限速脚本就会自动关闭,又打开了本来3M的限速了!

  基本上原理就是这样。通过这个原理,网吧宽带利用就会越来越合理!

  :for aaa from 1 to 254 do={/queue simple add name=(PC . $aaa) dst-address=(192.168.0. . $aaa) limit-at=500000/500000 max-limit=3000000/3000000}

  / ip firewall mangle

  add chain=prerouting action=mark-packet new-packet-mark=all-mark \

  passthrough=yes comment="" disabled=no

  / queue type

  add name="PCQ-up" kind=pcq pcq-rate=1500000 pcq-limit=50 \

  pcq-classifier=src-address pcq-total-limit=2000

  add name="PCQ-down" kind=pcq pcq-rate=1500000 pcq-limit=50 \

  pcq-classifier=dst-address pcq-total-limit=2000

  / queue simple

  add name="PCQ" target-addresses=192.168.0.0/24 dst-address=0.0.0.0/0 \

  interface=all parent=none packet-marks=all-mark direction=both priority=1 \

  queue=PCQ-up/PCQ-down limit-at=0/0 max-limit=15000000/15000000 \

  total-queue=default-small disabled=yes

  / system script

  add name="PCQON" source=":if \(\[ /queue sim get \[/queue sim find \

  name=\"PCQ\"\] disable \]=true \) do={/queue sim enable PCQ}" \

  policy=ftp,reboot,read,write,policy,test,winbox,password

  add name="PCQOFF" source=":if \(\[ /queue sim get \[/queue sim find \

  name=\"PCQ\"\] disable \]=false \) do={/queue sim disable PCQ}" \

  policy=ftp,reboot,read,write,policy,test,winbox,password

  / tool traffic-monitor

  add name="PCQON" interface=WAN traffic=received trigger=above \

  threshold=14800000 on-event=PCQON comment="" disabled=no

  add name="PCQOFF" interface=WAN traffic=received trigger=below \

  threshold=5000000 on-event=PCQOFF comment="" disabled=no

网友评论
<