鸿 网 互 联 www.68idc.cn

当前位置 : 服务器租用 > 操作系统维护 > vmware > >

before you can run vmware several modules must...解决

来源:互联网 作者:佚名 时间:2015-04-10 15:25
before you can run vmware several modules must...解决 一个月前,因为更新了ubuntu12.04的内核,然后导致虚拟机VMware 直接不能用了,搞了一个多月也没搞出来,真是头疼死了。今天终于弄好了。 废话不多说。直接贴问题: be【本文来自鸿网互联 (http://ww
before you can run vmware several modules must...解决
 
 一个月前,因为更新了ubuntu12.04的内核,然后导致虚拟机VMware 直接不能用了,搞了一个多月也没搞出来,真是头疼死了。今天终于弄好了。
废话不多说。直接贴问题:
be【本文来自鸿网互联 (http://www.68idc.cn)】fore you can run vmware several modules must be compiled
 
每回启动VMware的时候总是出现这个问题,然后就出现一个对话框。
解决方法:进入这个网站:http://pavlinux.ru/vmware/
根据你虚拟机的版本号,点击相应的链接。然后根据提示install:输入相应的命令
 
  大部分人完成以上步骤以后,就可以顺利的运行VMware了。但是我的机子有抽搐了!!在运行最后一条命令的时候又出现了一个错误:
gcc:error trying to exec 'cc1' execvp no such file or directory
gcc and linux kernel header must be installed first
真是蛋疼啊,gcc和linux header 我都装好了啊,而且我的gcc还能编译各种C语言程序呢!!! 基本上就是这个问题困扰了一个月!其中,我不停的在gcc-4.4 与 gcc-4.6 之间更换gcc的版本。 而且不停的卸载gcc,然后重装。
还有: 1、之前将gcc从ubuntu自带的gcc-4.6降到gcc-4.4,网上给了很多方法,我也试过了。但是还是出现了如下错误:
gcc-4.6: error trying to exec 'cc1'。
瞬间感觉蛋裂了,我用命令 gcc -v 查看gcc的版本,明显显示的是gcc-4.4.7 同时也查看了gcc的软链接版本
最后,我想,可能是运行VMware的那条命令的时候:vmware-modconfig --console --install-all; 它需要使用gcc编译,但是它会检测系统中的gcc高版本或者由于gcc-4.6是系统自带的,可能在系统中有注册,所有,检测到的都是gcc-4.6.
在之前都只是安装了gcc-4.4,然后通过软链接把gcc链接到gcc-4.4中,而没有删除或者卸载gcc-4.6;
最后的方法:
 
1、卸载gcc-4.6 : sudo apt-get remove gcc-4.6
2、安装gcc-4.4
     sudo apt-get remove gcc
     sudo apt-get install gcc-4.4 g++-4.4
     sudo ln -s /usr/bin/gcc-4.4 /usr/bin/gcc
     sudo ln -s /usr/bin/g++-4.4 /usr/bin/g++
网友评论
<